Mozilla不再支援Firefox 4的安全更新


發佈: 2011-6-24 11:41 | 作者: hpek | 來源: MySky科幻網
注意:如果文中出現『*** Hidden to visitors ***』字樣,請轉至論壇瀏覽或下載。



文/陳曉莉 (編譯) 2011-06-23
       
因為Firefox 5就是Firefox 4的安全更新:根據Mozilla的發表藍圖,自Firefox 5以後,新的版本就會是前一代版本的安全更新。

Mozilla本周二(6/21)釋出最新的Firefox 5瀏覽器,距Firefox 4只有3個月,這市因為Mozilla於今年開始大幅縮短開發時程。對一般使用者而言可能是好事,但卻有開發人員認為這代表Firefox 4已屬終止產品,同時Mozilla也坦承不會再支援Firefox 4的安全更新,因為Firefox 5就是Firefox 4的安全更新。

Firefox 5除了讓不追蹤(Do Not Track on)功能適用於桌面版及Android行動平台外,也支援CSS動畫(CSS Animations)功能,並修補臭蟲及安全漏洞。

今年5月,先是有開發人員表達想要停留在Firefox 3.6的意願,因為所開發的程式無法支援Firefox 4,隨後的討論則將話題轉移到Mozilla對產品的支援策略。根據Mozilla的發表藍圖,自Firefox 5以後,新的版本就會是前一代版本的安全更新。

Mozilla負責協調社群的Asa Dotzler表示,在現有版本發表後,Mozilla將會提供上一代版本最多6個月的安全更新,也許當Firefox出現重大漏洞時,Mozilla會釋出緊急更新,但這並不在計畫內,因為Firefox 4的安全更新就是Firefox 5。

Dotzler強調,Mozilla會選擇對大多數使用者是有利的方式,不過,最多6個月意味著就算Mozilla在推出Firefox 5時就終止對Firefox 4的支援也不算違背該政策。

相關爭議源自於Mozilla加快了Firefox的開發速度,今年內可望再發表Firefox 6及Firefox 7,對使用者而言,可更快使用穩定且具新功能的Firefox,但對開發人員卻帶來額外的負擔,因為開發人員必須不斷因應新的版本而修改支援Firefox的擴充程式。

為了保護使用者的安全,Firefox能夠自動偵測不相容於現有版本的擴充程式,Mozilla介面設計師Alexander Limi指出,新版Firefox的快速釋出也代表開發人員也必須加快升級腳步。(編譯/陳曉莉)
 
 


注意:如果文中出現『*** Hidden to visitors ***』字樣,請轉至論壇瀏覽或下載。


 

 

Hostgator PhotonVPS

網絡資源